Codec Multimediali su Fedora Core 7

Per installare i codec apriamo la shell, diventiamo root e diamo questi comandi singolarmente:

wget ftp://mplayerhq.hu/MPlayer/releases/codecs/all-20061022.tar.bz2tar xjf all-20061022.tar.bz2
mkdir /usr/lib/win32
mv all-20061022/* /usr/lib/win32
rm -fr all-20061022

Fedora java runtime engine jre e java development kit jdk e firefox plugin

Installo i pacchetti necessari:
yum install compat-libstdc++-296.i386 compat-libstdc++-33.i386
Installiamo la jre e la jdk
Andiamo su
http://java.sun.com/javase/downloads/index.jsp
e scarichiamo la jdk (ultima versione formato rpm)

chmod ugo+x jdk-6u1-linux-i586-rpm.bin
./jdk-6u1-linux-i586-rpm.bin
rispondere yes per accettare la licenza

[root@trinity2 ~]# ls /usr/bin/java -la
lrwxrwxrwx 1 root root 22 12 giu 20:56 /usr/bin/java ->
/etc/alternatives/java
[root@trinity2 ~]# ls -la /etc/alternatives/java
lrwxrwxrwx 1 root root 35 12 giu 20:56 /etc/alternatives/java ->
/usr/lib/jvm/jre-1.5.0-gcj/bin/java
[root@trinity2 ~]# rm /etc/alternatives/java
rm: rimuovere link simbolico `/etc/alternatives/java’? y
[root@trinity2 ~]# ln -s /usr/java/jdk1.6.0_01/bin/java
/etc/alternatives/java

[root@trinity2 ~]# java -version
java version “1.6.0_01”
Java(TM) SE Runtime Environment (build 1.6.0_01-b06)
Java HotSpot(TM) Client VM (build 1.6.0_01-b06, mixed mode, sharing)

adesso abilitiamo il plugin per firefox
[root@trinity2 ~]# ln -s
/usr/java/jdk1.6.0_01/jre/plugin/i386/ns7/libjavaplugin_oji.so
/usr/lib/firefox-2.0.0.4/plugins/

Installare Macromedia Flash Player su Fedora Core 7

da root

nano /etc/yum.repos.d/macromedia.repo e copincolliamo e salviamo questo

[macromedia]
name=Macromedia for i386 Linux baseurl=http://macromedia.rediris.es/rpm/ #baseurl=http://macromedia.mplug.org/rpm/ #baseurl=http://sluglug.ucsc.edu/macromedia/rpm/ enabled=1 gpgcheck=1 gpgkey=http://macromedia.rediris.es/FEDORA-GPG-KEY

e con questo abbiamo addato il repo Macromedia (serve solo per FlashPlayer).

yum -y install flash-plugin

Fedora 10 – Could not create a python script engine for plasmoid

This is my solution:

Remove any plasmoid and its directory in $HOME/.kde/share/apps/

yum remove kdebase-workspace-python-applet

yum install python-dev compat-python24-devel.i386 compat-python24-tools.i386 dbus-python-devel.i386 gnome-python2-devel.i386 ipython.noarch  pymol-wxpython.i386 python-devel.i386 python-fedora.noarch python-py.i386 python-pysctp.i386

yum install kdebase-workspace-python-applet

the re-install plasmoid with command:

plasmapkg -i plasmoid

plasmapkg -i 101229-gmail-plasmoid-0.7.3.plasmoid